**Chapter 6**

**MIDI:** *Musical Instrument Digital Interface* is a communications protocol.
- MIDI devices transmit performance data via MIDI messages 1-bit at a time.
- Up to 16 MIDI channels of data can be sent over a single MIDI cable.
- A MIDI sequencer allows you to store, edit and play back MIDI information.
- To enable input from a MIDI device, choose Setup>MIDI>Input Devices and select MIDI device(s) to receive MIDI input from.

**Pro Tools provides two types of track for working with MIDI data:**
- **MIDI tracks** - often used in conjunction with Auxiliary Input tracks for monitoring playback. The MIDI Input selector in the Edit or Mix window is the functional equivalent to the Audio Input Path selector for and audio track.
- **Instrument tracks** – Combines a MIDI track and an Auxiliary Input into one track. Only records MIDI data. The MIDI Input selector appears in the Instrument MIDI Controls Section of the Edit or Mix window.

**Sample-Based versus Tick-Based operation:**
- **Audio is Sample based** – audio regions – “absolute location” – doesn’t move if tempo changes (Audio tracks can be changed to Tick-based so that their regions will move with tempo changes)
- **MIDI data is “Tick” based, “relative location”, i.e. MIDI regions will move if tempo changes in session.** (Midi tracks can be changed to Sample-based so that they won’t move or conform to new tempo when tempo is changed)

**MIDI usually uses the Bars|Beats time base ruler:**

<table>
<thead>
<tr>
<th>Bar number</th>
<th>Beat number</th>
<th>Tick number</th>
</tr>
</thead>
<tbody>
<tr>
<td>960</td>
<td></td>
<td>480 per eighth, 240 per sixteenth</td>
</tr>
</tbody>
</table>

**MIDI Transport Controls:** To display, select Window>Transport>MIDI Controls
- **Wait for Note** – when enabled, begins recording when you begin playing.
- **Metronome Click** – toggles click off and on. Also, Options>Click. (Go to Setup>Click/Countoff… opens dialog box to change options like “During play and record” or “Only during record” or “Only during countoff”). Keyboard shortcut = 7
- **Count Off** – click will count off a specified number of measures before recording begins. Keyboard shortcut = 8
- **MIDI Merge** – once MIDI is recorded, MIDI Merge allows multiple overdubs to be recorded to the same region without erasing any previous recorded data. Keyboard shortcut = 9
- **Conductor** – when selected, Tempo Map for session is used. When de-selected, Manual Tempo setting is used; type in a tempo or use Tap Tempo (T) when tempo display area highlighted.
**MIDI Events Operations**: Go to Event>Event Operations> Event Operations Window (Alt+3) to choose MIDI global functions like; quantize, quantize input, Change Velocity, Change Duration, Transpose, etc. (read about Input Quantize functions on page 155)

**MIDI Thru**: Turn on via Options>MIDI Thru
- Must be enabled to monitor MIDI-compatible tracks while recording.
- Must be enabled when using an Instrument track to record MIDI, if not enabled, the track will not receive a MIDI signal.
- **Disable LOCAL CONTROL on MIDI keyboards** that generate their own sounds, to avoid “double” MIDI notes. If you don’t, Pro Tools will “forward” notes back to the keyboard, AND the keyboard will also play notes via its internal sending of data from what you play to its internal sound generation engine.

**Conductor Rulers** (tempo, meter, markers and Key) – useful for MIDI and Bars-and-beats based editing.
- Default Meter is 4/4
- Default Tempo is 120 bpm
- Default Key is C major

**Viewing MIDI Data on MIDI Compatible Tracks**: page 169
- **Notes View** = “piano roll” view of MIDI notes
- **Regions View** – shows notes, but they cannot be individually edited. Regions act as “containers” for MIDI events (notes, other MIDI data).
- **Velocity View** – volume “stalks” allow editing of volume of MIDI notes. (The “meter” on a MIDI track is a **Velocity Meter**, showing MIDI velocity values 0-127.)
- Use Ctrl+- to switch view from region to note. If Zoom Toggle is active, pressing Ctrl+- will toggle between Notes view and Velocity view.
- The Mini Keyboard can be viewed in Region, and Notes view only.
- Pencil tool turns into **Eraser** for MIDI notes by clicking **Option (alt)** while Pencil tool active.

**Virtual Instruments**: Instantiated through AUX tracks or Instrument tracks inserts. Create an AUX track, use Inserts to select virtual instrument. Then, use MIDI track’s Output selector to route the MIDI data to the virtual instrument.
- **Xpand2 – Soft Synth**. Digidesigns Advanced Instrument Research (A.I. R.) division. Has four individual parts (A,B,C,D) which are layered together to produce a rich textures or a drum/perc kit. 2,300 Patches (plug-in settings), 1,200 combinable Parts (sound presets)
- **Structure Free – Sample player**. Digidesigns A.I.R. division. 60 preset patches. 64-voice multi-timbral sound engine. Some programs use Key Switches. Loads Native Structure, SampleCell, SampleCell II, Kontakt, Kontakt 2, EXS 24 libraries.

---

**Chapter 7**

**Universe View** – new to version 8, displays an overview of entire session. Accessed through View>Other Displays>Universe.

**Two types of Selections: Time Line and Edit selections (defaults to linked)**

With the **“Link Timeline and Edit Selection”** enabled, a Timeline selection is also made whenever you select audio or MIDI data on a track. Normally this is enabled.
**Time Line Selections:** Used to set the playback and record range. Indicated by blue up and down marker arrows (red if a track is record enabled).

- Can be made from any Timebase Ruler (not conductor) with any tool. (Will turn into the Selector tool when moused over the ruler)
- During playback, use the down/up arrows to set in/out marker points. (dn = in, up = out)
- Hold Shift and click on Time Line Ruler, (or track if linked with edit selection) or click and drag to adjust time line markers
- Use the Time Line Selection fields (Transport window)
  1. Click on any field and type in value. All fields to the right will zero out when you enter.
  2. Click on any field and use up/down arrow to change value. All fields to the right will stay the same.
  3. Click any field and use the + - (plus minus) keys and enter a value. It will add or subtract that value to the current value. All fields to the right will stay the same.
  4. Use the slash key (/) to move between the start, end, and length boxes.
- Grab and drag the Time Line Markers. Use any tool; it will turn into the Grabber when moused to a Time Line Marker.
- Hold Option/Alt key and drag either marker. The whole selection range will move.

**Edit Selection:** Used to set an edit range. Can be made in any track, or multiple tracks.

- Can be made from any Conductor Ruler (not Time Line)
- Use the Edit Selection fields (Edit window)
  1. Click on any field and type in value. All fields to the right will zero out when you enter.
  2. Click on any field and use up/down arrow to change value. All fields to the right will stay the same.
  3. Click any field and use the + - keys and enter a value. It will add or subtract that value to the current value. All fields to the right will stay the same.
  4. Use the slash key (/) to move between the start, end, and length boxes.
- Grab and drag the Edit Markers. Use any tool; it will turn into the Grabber when moused to a Edit Marker.
- Hold Option/Alt key and drag either marker. The whole selection range will move.

**Making Edit Selections on Multiple Tracks:**

- Adjacent Tracks – Click and Drag vertically across tracks with Selector tool.
- Non-Adjacent Tracks – After making initial selection, use the Selector tool, Shift+Click on tracks you want to add.
- With “Link Track and Edit Selection” enabled, Command+Click on the name plate of any track.

**Using the Tab Key:**

- Use the Tab key to move the cursor from region boundaries on single or multi-tracks. (Hold down Option key to go to previous boundry)
- Tab to the next MIDI note in a MIDI compatible track. (Hold down Option key to go to previous note)
Tab to Transients:
- Goes to next “spike” on track when enabled. (The Tab to Transients threshold is set by Pro Tools and is not user adjustable)
- Hold down the Option key to change direction and move cursor earlier when using tab to transient.

Memory Locations
- **999** Total Memory Locations
- Press ENTER (on keypad) to store Mem Loc in next available slot. Can also be done on-the-fly.
- Or press period (.) number then ENTER (on keypad)
- Can store as Marker, Selection, or None.

Recall mem loc: . nnn . (numeric keypad)
- Or click marker (marker ruler)
- Or select in Mem Loc window (cmd+5) and click marker

Auto Name Mem Loc: if you have selected Marker as your default type, name will be “Marker nn” or else name will be based on Main Time Scale.

Change/re-define a Mem Loc:
1) show mem loc window
2) put system in desired new state
   (cursor loc, selection, track height, etc.)
3) Ctrl-click (right-click on PC) Mem Loc button you want to change, or use .nnn <enter>
4) Make changes in Mem Loc dialog box
5) Click OK

Delete Mem Loc: Mem Loc window, and Option (alt) click marker. Works in Marker ruler as well.
OR select a range in the Markers ruler, and press DELETE key

Make a selection between two Mem Locs: Click the first Mem Loc, hold SHIFT, and click the 2nd Mem Loc. Or, shift+tab to next memory location.

---

**CHAPTER 8**

Scrolling:
- No Scrolling
- After Playback
- Page
- Continuous Scrolling (HD or DV Production Toolkit)

Loop Playback: continuous playback of session between in and out points of Time Line
- Options>Loop Playback, or â on numeric keypad
Four Edit Modes:
- **Shuffle** (F1)
- **Slip** (F2) Default mode
- **Spot** (F3)
- **Grid** (F4)
- Scroll edit modes using the ~ key

Editing Regions: pg 212 - The Following Commands can be found in the Edit Menu
- **Cut** – (cmd+X) cuts selection from track and places material on the clipboard for use elsewhere.
- **Copy** – (cmd+C) copies selection from track and places material on the clipboard.
- **Paste** – (cmd+V) inserts the contents of the clipboard into the location chosen with the selector tool.
- **Clear Command** – (cmd+B) Removes selected regions without placing material on the clipboard.
- **Duplicate Command** – (cmd+D) copies a selection and duplicates it immediately after the end of the selection. (in shuffle mode everything is moved to the right to allow for insertion)
- **Repeat Command** – (Option+R) like duplicate command, but allows you to specify the number of times the material will be copied.

Pro Tools Specific Editing Commands: pg 216 Working with Regions
- **Capture Command** – (cmd+R) Defines a selection as a new, independent region and adds it to the Region List without creating a separation in source location.
- **Separate Region Command** – (cmd+E) Split a region at insertion point or separating a section of an original region into a new region.
- **Separate Region – On Grid or At Transients** - automatically create regions based on a defined timing or based on audio events on the track.
- **Heal Separation Command** – (cmd+H) repairs separations and restores the original unedited material.

Moving and Trimming Regions: pg 219
- **Slip Mode** - See Table 8.1 pg 220 for moving regions in slip mode and their results.
- **Grid Mode** – Results are the same as except dragging regions is constrained by current Grid Value.
- **Shuffle Mode** – When moving, regions snap to each other but cannot leave space between them or overlap them.
- **Spot Mode** – When moving, Spot dialog box pops up and you select the time scale and location. The result of overlapping regions is the same as in Slip Mode.

Trim Functions: pg 222
- **Trim Tool** (standard mode) will trim the beginnings and ends of a region obeying the functions of the Edit Mode that you currently in, ie. Slip, Shuffle, Grid or Spot.
- **Trim Command** (cmd+T - also Edit Menu) select range within a region and trims (clears) the audio in front and after selected range.

Nudge Function: pg 225 increment placement adjustment of regions and /or selections.
**Nudging Regions** – Select Region(s) and use +/- keys to nudge later or earlier in track by Nudge Value.

**Nudging Selections** – nudge start times (Option+Shift +/-) and end times (cmd+shift +/-) of a selection by Nudge Value.

**Using Fades:**
Fades are actually new audio files, in Fades folder.

**Fades are first calculated in RAM,** then rendered to disk as a fade file.

Make a selection, Edit>Fades or Command (Ctrl)-F

**Creating Fade Effects:** pg 228

3 major types: (cmd+F)

- **Fade-In, Fade-Out, Cross-Fade**
  - Preset (7 of them, not editable), Standard (editable), S-Curve (editable)

- **Smart Tool can create fade in/outs and x-fades**
  - (Track height must be medium)

- **Edit existing:** double-click w/Grabber
- **Delete:** Click w/Grabber, press Delete key
- **Delete one or more:** make a selection including fades, then Edit > Fades > Delete Fades.
- **Trick:** You cannot cross fade between two Whole files regions, only two sub-regions. Reason is there must be “more media (samples) to fade from and to, beyond region boundaries”.
- **You can Trim fades** from beginning OR end, using Trimmer tool.
- **Trimming fades in Shuffle mode may affect timing, sync, and position,** just like regular Shuffle-mode editing.
- **Cross fades do not have to be “centered”** around a splice point.
- **Link:** Equal Power – retain more of their amplitude longer, versus Equal Gain. Can avoid volume drop sometimes occurring with Equal Gain cross fades.
- **Link:** Equal Gain – can avoid clipping that sometimes occurs with Equal Power cross fades.
- **“None” option** in Link means the outgoing and incoming fades are independently editable.
- **Use DITHER option** when fading low-level signals or fading in/out to/from silence.

**Batch cross fades:** Select a group of regions, then Edit > Fades; dialog box will come up with many options.

**Undo:** 32 levels of undo is the max

Cannot undo:

- Delete Track
- Close Session
- Clear Audio from Regions List
- Destructive Recording

**Revert To Saved** – (File>Revert to Saved) If you need to undo changes that are not available in the Undo History Queue, you can use this command to restore the last saved version of your session.